The warranty cover 24 months? What will be guaranteed in the 24 months?

We promise that all products of Tank X series will be backed by a 24-MONTH WARRANTY.

SMOROBOT will provide you with warranty service for all parts and components of the whole machine for 24 months. No matter when or where you placed order.

Different from the traditional brands of pool cleaners, our 24-month warranty covers all parts and components of the robot, without restriction on the electrical parts.

For more information, please refer to the warranty terms shipped together with the product.

1 Like

How do I file a claim? I bought the X11 from kickstarter. I used it 5 times and it worked great. Now it won’t turn on after charging. Not sure what to do?

Hi, there

Feedback received.
Let me contact you for more information to better locate the problem.

Rosalina.

I bougth my smothrobot from kikstarter
I used two times whith a lot oh success and when I try to charged it again I think the charg port began in conflit and stop charging and never work anymore
Please told what to do
vcalisto@yahoo.com
PORTUGAL

We also received your email. We will continue contacting you through emails. Thanks.

Hi Rosalina,
My Smorobot is malfunctioning. It will run for a while then go up the wall, turn over, then go around in circles on the pool surface, and then sink and stop. I restart it, and it does the same thing. Please advise. Thanks.

Stu Hudson

Hi, Stu Hudson

The robot will first clean the wall and then the floor no matter in S or F mode.

Can you send us a video to help us better understand the problem? Please send to community@smorobot.com since it’s not supported to upload videos here.

Rosalina

Rosalina,

I understand that it cleans the walls first and then the floor. This is what it did when we first got it. The problem is that it will only do this for about five minutes and then it malfunctions as I previously described. I will send a video when I get a chance. Thanks.

Stu

1 Like

Rosalina,

I’ve tried to send videos, but they won’t send because they are too big to send over email. Is there another way to upload them? This is getting very frustrating!

Stu

You can upload the videos to Google drive and share the link with me.

Hi, there
I saw the two videos. Please keep the pump off when using our robot.
Have another try and let me know the result.
Rosalina

Good Afternoon Rosalina,

No luck, it still does the same thing with the pump off. It seems to be the walls that are causing the malfunction. As I said before, it goes up the wall, and at the top, it turns upside down, then starts spinning in circles. Would it be possible to exchange this one for one that does floors only?

Stu

I got your informations registered.
We will mail you a programming line so you can get your robot upgraded to floor only version.

Rosalina

My robot cleaned the pool and functioned perfectly for 2 days. Today it started cleaning the pool walls as it has in the past and then just stopped working. No indicator light, cannot switch it on or off. What do I do? Thanks

When I plug the charger into the robot the charger has a red light instead of green. Is there a fuse in the robot that needs to be reset?

When charging, the charger will have a red light until fully charged, it will turn green.
Please make sure your robot has enough battery.

my bot is dead again, i had my 1st bot replaced. i have sent a email request to customer service ticket 2006 a week ago dec 7 , no replies. bots problem should be in ticket from my email,
WHAT do you suggest now?
I’m starting to think this product is not ready for market.

Hi, there.
Sorry to keep you waiting for so long.
I saw Jane is in charge of your case and she will reply you very soon.
Please don’t worry. We will do our best to help.

Hi Tdog, have you fixed it? I have same issue here. Mine still only on red, no matter how many hours/days in charger and do not turn on anymore.

It did take a charge and was functioning fine but now I am in the same situation as you. The robot cleaned the pool as normal. I pulled it out cleaned the strainers, flushed with fresh water and hooked up to charger to recharge. No indicator lights on the robot and it has been plugged in for 6 hrs with no change. The charger itself shows a red light so I know it is supplying power to the robot, the robot is just not taking a charge. I’ll keep you posted.